Podpora konferencí Meetme s pomocí časovače dahdi_dummy

Informace o novinkách a změnách na 4smart.cz

Podpora konferencí Meetme s pomocí časovače dahdi_dummy

Příspěvekod admin » úte 08. úno 2011 17:09:37

Dnes byla vyřešena problematika podpory konferencí založených na Meetme(). Do jádra byl začleněn modul DAHDI (dahdi_dummy), který zajišťuje potřebné časování a nahrazuje původní, nefunkční modul zaptel. Podpora konferencí Meetme() se týká nově vytvořených virtuálních serverů bez ohledu na šablonu.
Do večeních hodin bude podpora konferencí zprovozněna i v existujících virtuálnech. V 15:50 byl spuštěn script, který postupně pro každý VPS provede nutná nastavení. Vše by mělo být hotové kolem 17:00.

Ve vašich stávajících virtuálních serverech přibyde:
/dev/dahdi/
/usr/include/dahdi/user.h

Uvedený hlavičkový soubor user.h zajistí možnost zkompilovat Asterisk s podporou DAHDI a app_meetme. Pokud budete požadovat do vašeho asterisku přidat podporu konferencí, neobejdete se bez rekompilace. Nemusíte však v jejím průběhu cokoliv řešit. Postačí trojice ./configure, make, make install.
Vaše původní nastavení ústředny vám v /etc/asterisk/ zůstane.

Podporu meetme() jsme ověřili za pomoci Asterisku verze 1.8.2.3.

POZN.: Alternativou k Meetme(), které vyžaduje časovač dahdi_dummy a nově zkompilovaný asterisk je ConfBridge. Tato aplikace je od jisté verze Asterisku zcela nezávislá na externím časovači a zajišťuje téměř stejnou funkcionalitu, včetně možnosti uzamknutí konference.

J. Marák
admin
Administrátor
 
Příspěvky: 1372
Registrován: úte 12. říj 2010 9:16:11

Zpět na Novinky na 4smart.cz

Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 1 návštěvník